Tuesday, June 3, 2008

How to Eliminate Annoying Pops and Clicks With Your PC Audio Interface

I recommend that you record your playing for an unbiased measure of progress. The only downside for me has been time spent trying to diagnose annoying pops and clicks instead of playing the guitar. Although it seemed to be a complicated problem, the solution was simple and hopefully this can save you time if you have the same problem.

Pops and clicks with a PC audio interface are usually caused by the buffer size being too small. Buffers serve the same purpose as your local water tower. As long as the water department keeps a sufficient level of water in the tank you’re ensured a continuous stream of water and won’t be stranded mid shower. Your Operating System (OS) is like the water department; as long as it comes back often enough to refill the buffers you’ll get the continuous audio stream your audio interface needs. The smaller the buffer the more likely the OS will miss refilling it on time and you end up with the audio interface version of an interrupted shower; pops and clicks.

I increased the buffer size (essentially a larger water tank) to the point the pops and clicks went away but ended up with an unusable level of latency (you don’t hear your playing until it goes through the input buffers to your recording software then back through your output buffer through the soundcard and into whatever you are using to monitor such as headphones). The larger the buffer the longer the delay.

I use a PODxt as my audio interface and the Line6 website had articles on how to use a computer with Line6 gear. My thought until then had been that a new and relatively powerful computer in terms of RAM, CPU, and hard drive speed with the audio drivers properly installed should be golden. Not so it turns out. Seems the newer the computer the busier it is. If it is too busy (no matter how powerful) it doesn’t keep the buffer filled consistently. Duh! Seems perfectly reasonable and wish I had thought of it.

Following recommendations I disabled my wireless card, went into performance options through “My Computer” and set it to “Adjust for best performance”, and disabled a lot of programs set to start automatically with Windows and my Vista base performance score increased by 40%! I set the PODxt audio interface back to optimal latency (small buffer size) and no surprise, it came out sounding great. Now I can get back to actually playing the guitar!

blog comments powered by Disqus

Post a Comment


Google